Cisco 827/827H/SOHO97/837 Basic Configuration

This recipe is designed for those Cisco 827’s that have the “basic” feature set (i.e. do not have firewall or VPN software). Having said that, this configuration will work on every 827 shipped in NZ to date, but it wont use the fancier features of the firewall or VPN feature sets.

To use this configuration, download the template file, 827_basic_nz.tpl, and use Cisco FastStep to install it.

A configuration created with this template will look something like:

                no service pad 
                service timestamps debug uptime
                service timestamps log uptime
                service password-encryption
                !
                hostname router
                !
                logging buffered 4096 debugging
                !
                !
                ip name-server <Name Server 1> <Name Server 2>
                !
                !
                !
                ip subnet-zero
                ip dhcp excluded-address 192.168.1.1 192.168.1.100
                ip dhcp excluded-address 192.168.1.254
                !
                ip dhcp pool dhcppool
                  import all
                  network 192.168.1.0 255.255.255.0
                  default-router 192.168.1.254
                  dns-server <Name Server 1> <Name Server 2>
                !
                !
                clock timezone NZST 12
                clock summer-time NZDT recurring 1 Sun Oct 2:00 3 Sun Mar 3:00
                !
                !
                !
                interface Ethernet0
                  ip address 192.168.1.254 255.255.255.0
                  ip nat inside
                !
                interface ATM0
                  no ip address
                  no atm ilmi-keepalive
                  dsl operating-mode auto
                !
                interface ATM0.1 point-to-point
                  pvc 0/100
                    encapsulation aal5mux ppp dialer
                    dialer pool-member 1
                  !
                !
                interface Dialer0
                  bandwidth 640
                  ip address negotiated
                  no ip redirects
                  no ip unreachables
                  ip nat outside
                  encapsulation ppp
                  dialer pool 1
                  dialer-group 1
                  ppp pap sent-username <username> password <password>
                  ppp ipcp dns request
                  no cdp enable
                !
                ip nat
                inside source list 1 interface Dialer0 overload
                ip classless
                ip route 0.0.0.0 0.0.0.0 Dialer0
                no ip http server
                !
                banner motd |Orignal config (c)IFM Ltd sales@ifm.net.nz, prepared by IFM Ltd/sales@ifm.net.nz|
                !
                line vty 0 4
                  access-list 1 in
                exit
                !
                access-list 1 permit 192.168.1.0 0.0.0.255
                dialer-list 1 protocol ip permit
                

Cisco Systems Partner - Premier Certified